We have consolidated our SASE status page components for improved clarity and better service visibility. All changes, migration details, and component mappings are thoroughly documented for your reference.
The most up-to-date list of products is displayed below. Regional impact details and workarounds will be included in incident descriptions when applicable.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 23, 2025 - 09:00 UTC
Scheduled
We will be performing infrastructure upgrades to increase the bandwidth of our resources in the global regions. As part of this maintenance, we will replace the current resources with a larger one that provides higher bandwidth for customer-facing services. No customer impact.
Posted Nov 21, 2025 - 17:49 UTC
This scheduled maintenance affected: Prisma Access Browser - US Region (Browser Access), Prisma Access Browser - EU Region (Browser Access), and Prisma Access Browser - SG Region (Browser Access).