PAB US - Degraded performance in Profile Sync service for some users

Incident Report for Prisma SASE

Resolved

This incident has been resolved.
Posted Jul 13, 2025 - 11:28 UTC

Identified

We're currently experiencing a disruption with our sync service. While you can continue using the browser normally, it may fail pulling synced data across other devices or when logging into a new profile.
Please be assured that any new entries you make will be safely stored and will sync across all your devices once the service is restored. We're working to fix this as quickly as possible.
Posted Jul 13, 2025 - 10:06 UTC
This incident affected: Prisma Access Browser - US Region (Browser Updates).