We have consolidated our SASE status page components for improved clarity and better service visibility. All changes, migration details, and component mappings are thoroughly documented for your reference.
The most up-to-date list of products is displayed below. Regional impact details and workarounds will be included in incident descriptions when applicable.
Status: Completed Scheduled Window: December 21, 2025, 09:00 - 16:00 (UTC) Affected Locations: Ashburn Customer Impact: Session recording and Screenshots will be unavailable during the maintenance
Thank you for your patience.
Posted Dec 21, 2025 - 16:04 UTC
In progress
Update: Status changed to In Progress.
Status: In Progress Scheduled Window: December 21, 2025, 09:00 - 16:00 (UTC) Affected Locations: Ashburn Customer Impact: Session recording and Screenshots will be unavailable during the maintenance
We will continue to provide updates as maintenance progresses.
Posted Dec 21, 2025 - 09:04 UTC
Scheduled
Scheduled maintenance for Admin Console
Status: Scheduled Scheduled Window: December 21, 2025, 09:00 - 16:00 (UTC) Affected Locations: Ashburn Customer Impact: Session recording and Screenshots will be unavailable during the maintenance
We will provide updates when maintenance begins.
Posted Dec 18, 2025 - 16:16 UTC
This scheduled maintenance affected: Prisma Browser (Admin Console).